您的位置:首页 > 其它

2004成绩转换

2016-06-22 10:25 260 查看
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 118849    Accepted Submission(s): 52199


Problem Description

输入一个百分制的成绩t,将其转换成对应的等级,具体转换规则如下:

90~100为A;

80~89为B;

70~79为C;

60~69为D;

0~59为E;

 

Input

输入数据有多组,每组占一行,由一个整数组成。

 

Output

对于每组输入数据,输出一行。如果输入数据不在0~100范围内,请输出一行:“Score is error!”。

 

Sample Input

56
67
100
123

 

Sample Output

E
D
A
Score is error!

 

#include<iostream>
#include<stdio.h>
using namespace std;

int main(){
int score;

while(cin>>score){
if(score>=90&&score<=100){
cout<<"A"<<endl;
}
if(score>=80&&score<=89){
cout<<"B"<<endl;
}
if(score>=70&&score<=79){
cout<<"C"<<endl;
}
if(score>=60&&score<=69){
cout<<"D"<<endl;
}
if(score>=0&&score<=59){
cout<<"E"<<endl;
}
if(score<0||score>100){
cout<<"Score is error!"<<endl;
}
}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: