您的位置:首页 > 其它

Poj 3041 Asteroids【最小点覆盖】

2016-06-21 12:32 267 查看
Asteroids
Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 19767

 

Accepted: 10728

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find
the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 

* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4

1 1

1 3

2 2

3 2

Sample Output

2

Hint

INPUT DETAILS: 

The following diagram represents the data, where "X" is an asteroid and "." is empty space: 

X.X 

.X. 

.X. 

OUTPUT DETAILS: 

Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

USACO 2005 November Gold

题目大意:有n*n这么大个图,其中有小行星K个,接下来K行表示小行星的位子,然后现在主角有一个武器,每一次使用都可以对其中的一行或者一列的小行星进行摧毁,问最少使用多少次武器可以把所有的小行星都干掉。

思路:典型的最小点覆盖问题。对于二分匹配建边的理解:

要么这把武器横着打,要么武器竖着打,而且当前这个点随意被哪一种武器方式打到,它一定会被打掉。

最大二分匹配==最小点覆盖数。

那么直接求一下最大二分匹配数即可。

AC代码:

#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
vector<int >mp[5050];
int match[5050];
int vis[5050];
int n,m;
int find(int x)
{
for(int i=0;i<mp[x].size();i++)
{
int v=mp[x][i];
if(vis[v]==0)
{
vis[v]=1;
if(match[v]==-1||find(match[v]))
{
match[v]=x;
return 1;
}
}
}
return 0;
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
memset(match,-1,sizeof(match));
for(int i=1;i<=n;i++)mp[i].clear();
for(int i=0;i<m;i++)
{
int x,y;
scanf("%d%d",&x,&y);
mp[x].push_back(y);
}
int output=0;
for(int i=1;i<=n;i++)
{
memset(vis,0,sizeof(vis));
if(find(i))output++;
}
printf("%d\n",output);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Poj 3041