您的位置:首页 > 其它

solution Of 1019. General Palindromic Number (20)

2016-06-19 20:32 387 查看
1019. General Palindromic Number (20)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line “Yes” if N is a palindromic number in base b, or “No” if not. Then in the next line, print N as the number in base b in the form “ak ak-1 … a0”. Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes

1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No

4 4 1

结题思路 :

题意要求我们将输出注册用户的用户群。

要求1:N、b均小于10^9;

要求2:经测试大于10进制的并不存在字符的转化问题。

程序步骤:

第一步、对读入的数用指定的进制表示A;

第二步、对A进行逆序保存到B;

第三步、将A与B进行“与”操作。

具体程序(AC)如下:

#include <iostream>
#include <vector>
#include <string>
#include <cstring>
#include <algorithm>
using namespace std;
vector<int> bit;
void getN2b(int N,int b)
{
bit.clear();
while(N>b)
{
bit.push_back(N%b);
N=N/b;
}
bit.push_back(N);
}
int main()
{
int N,b;
cin>>N>>b;
getN2b(N,b);
vector<int> reversed=bit;
reverse(reversed.begin(),reversed.end());
int i;
for(i=0;i<bit.size();++i)
if(reversed[i]!=bit[i])
break;
if(i>=bit.size())
cout<<"Yes"<<endl;
else
cout<<"No"<<endl;
if(reversed.szie()>0)
{
cout<<reversed[0];
for(i=1;i<reversed.size();++i)
cout<<" "<<reversed[i];
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: