您的位置:首页 > 其它

Asteroids_poj3041_匹配

2016-06-18 13:38 337 查看
Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find
the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.

* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4

1 1

1 3

2 2

3 2

Sample Output

2

Hint

INPUT DETAILS:

The following diagram represents the data, where "X" is an asteroid and "." is empty space:

X.X

.X.

.X.

OUTPUT DETAILS:

Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

USACO 2005 November Gold

题目大意:

给出k个坐标表示小行星,每次可以清扫一行或一列的小行星,求最少清扫次数

思路:

连边小行星坐标x->y,求最大匹配数就是解。Poj提交意外地快,0ms+900k爽到爆

源代码:

#include <stdio.h>
#include <cstring>
using namespace std;
struct edge
{
int x,y,next;
};

edge e[10001];

bool v[501];

int n,k,ans=0,maxE=0;
int link[501],ls[10001];

void add(int x,int y)
{
e[++maxE].x=x;
e[maxE].y=y;
e[maxE].next=ls[x];
ls[x]=maxE;
}
bool find(int x)
{
for (int i=ls[x];i;i=e[i].next)
if (!v[e[i].y])
{
int p=link[e[i].y];
link[e[i].y]=x;
v[e[i].y]=true;
if (!p||find(p))
return true;
link[e[i].y]=p;
}
return false;
}
int main()
{
scanf("%d%d",&n,&k);
for (int i=1;i<=k;i++)
{
int x,y;
scanf("%d%d",&x,&y);
add(x,y);
}
for (int i=1;i<=n;i++)
{
memset(v,false,sizeof(v));
find(i);
}

for (int i=1;i<=n;i++)
if (link[i])
ans++;
printf("%d\n",ans);
return 0;
}


type
edge=record
x,y,next:Longint;
end;
var
e:array[1..1000000]of edge;
link,ls:array[1..1000]of longint;
v:array[1..1000]of boolean;
maxE,n,m:longint;
procedure add(x,y:longint);
begin
inc(maxE);
e[maxE].x:=x;
e[maxE].y:=y;
e[maxE].next:=ls[x];
ls[x]:=maxE;
end;
function find(x:longint):boolean;
var
i,k:longint;
begin
find:=true;
i:=ls[x];
while i>0 do
with e[i] do
begin
if not v[y] then
begin
k:=link[y];
link[y]:=x;
v[y]:=true;
if (k=0)or find(k) then exit;
link[y]:=k;
end;
i:=next;
end;
find:=false;
end;
procedure main;
var
i,ans:longint;
begin
ans:=0;
fillchar(link,sizeof(link),0);
for i:=1 to n do
begin
fillchar(v,sizeof(v),false);
if find(i) then inc(ans);
end;
writeln(ans);
end;
procedure init;
var
i,x,y:longint;
begin
readln(n,m);
for i:=1 to m do
begin
readln(x,y);
add(x,y);
end;
end;
begin
init;
main;
end.
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: