您的位置:首页 > 其它

hdu 1792 A New Change Problem(数论)

2016-06-17 21:10 387 查看


A New Change Problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1236    Accepted Submission(s): 737


Problem Description

Now given two kinds of coins A and B,which satisfy that GCD(A,B)=1.Here you can assume that there are enough coins for both kinds.Please calculate the maximal value that you cannot pay and the total number that you cannot pay.

 

Input

The input will consist of a series of pairs of integers A and B, separated by a space, one pair of integers per line. 

 

Output

For each pair of input integers A and B you should output the the maximal value that you cannot pay and the total number that you cannot pay, and with one line of output for each line in input.

 

Sample Input

2 3
3 4

 

Sample Output

1 1
5 3

题意:求a和b的最大不能组合数和不能组合数的个数

思路:a和b的最大不能组合数为(a-1)*b-a,不能组合数的个数为(a-1)*(b-1)/2

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

int main()
{
int n,m;
while(~scanf("%d %d",&m,&n))
{
printf("%d %d\n",(m-1)*n-m,(n-1)*(m-1)/2);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: