您的位置:首页 > 其它

Program4_B

2016-06-15 22:25 141 查看
 我现在做的是第四专题编号为1002的试题,主要内容是:

Problem B

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 38   Accepted Submission(s) : 8
[align=left]Problem Description[/align]
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it
can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.<br>Problem descriptions as follows: Given
you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?<br>
 

[align=left]Input[/align]
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point. <br><br>Input contains multiple test cases. Process
to the end of file.<br>
 

[align=left]Output[/align]
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points. <br>
 

[align=left]Sample Input[/align]

3
1.0 1.0
2.0 2.0
2.0 4.0

 

[align=left]Sample Output[/align]

3.41

 

简单题意:
给出n个点的坐标(二维x, y),可以使用直线(无向的)将任意两个点连接起来,求将所有点连接起来形成一个整体(使任何两点之间可达),线的最小距离。

解题思路:

最小生成树,用了两点间的距离公式,普利姆算法解决问题

编写代码:

#include<stdio.h>

#include<cstring>

#include<math.h>

double map[105][105];

int v[105];

double lowcost[105];

int n;

void init()

{

    int i,j;

    memset(v,0,sizeof(v));

    for(i=0; i<n; i++)

        for(j=0; j<n; j++)

            map[i][j]=1.7976931348623158e+308;

}

double prim(int u)

{

    int i,j;

    double min,mincost=0;

    v[u]=1;

        for(i=0; i<n; i++)

        lowcost[i]=map[u][i];

    for(i=1; i<n; i++)

    {

        min=1.7976931348623158e+308;

        for(j=0; j<n; j++)

            if(lowcost[j]<min && !v[j])

                min=lowcost[j],u=j;

        v[u]=1;

        mincost+=min;

        for(j=0; j<n; j++)

            if(lowcost[j]>map[u][j] && !v[j])

                lowcost[j]=map[u][j];

    }

    return mincost;

}

int main(){

    int i,j;

    double a[105],b[105];

    while(~scanf("%d",&n) && n) {

        init();

        for(i=0; i<n; i++)

            scanf("%lf%lf",a+i,b+i);

        for(i=0; i<n; i++)

            for(j=i; j<n; j++)

            {

                map[j][i]=map[i][j]=sqrt((a[i]-a[j])*(a[i]-a[j])+(b[i]-b[j])*(b[i]-b[j]));

            }

       printf("%.2f\n",prim(0));

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: