您的位置:首页 > 其它

HDU2602Bone Collector 简单0-1背包

2016-06-14 21:44 253 查看
Bone Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 48618 Accepted Submission(s): 20269



Problem Description

Many years ago , in Teddy’s hometown there was a man who
was called “Bone Collector”. This man like to collect varies of bones , such as
dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting
there are a lot of bones , obviously , different bone has different value and
different volume, now given the each bone’s value along his trip , can you
calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two
integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones
and the volume of his bag. And the second line contain N integers representing
the value of each bone. The third line contain N integers representing the
volume of each bone.

Output

One integer per line representing the maximum of the
total value (this number will be less than 231).

Sample Input

1

5 10

1 2 3 4 5

5 4 3 2 1

Sample Output

14

注意:先输入每个骨头的价值然后输入每个骨头的体积。

状态转移方程:dp[j]=max(dp[j],dp[j-v[i]]+w[i]。

#include <iostream>
#include <string.h>

using namespace std;
int N,V;
int dp[1111];
int w[1111],v[1111];
int main()
{
int t;
while(cin>>t){
while(t--){
cin>>N>>V;
for(int i=1;i<=N;i++){
cin>>w[i];
}
for(int i=1;i<=N;i++){
cin>>v[i];
}
memset(dp,0,sizeof(dp));
for(int i=1;i<=N;i++){
for(int j=V;j>=v[i];j--){       //j如果小于了v[i]那么v[i]一定无法装入袋子
dp[j]=max(dp[j],dp[j-v[i]]+w[i]);
}
}
cout<<dp[V]<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: