您的位置:首页 > 其它

A + B Problem II

2016-06-14 12:18 169 查看
Problem DescriptionI have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
InputThe first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
OutputFor each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


#include <iostream>
#include <iomanip>
#include <string>

using namespace std;
int main() {
int n ;
string str1,str2;
string large,small;
unsigned long l1,l2;
cin>>n;
int k = 1;
int number = n;
int count = 0;
int xl,xs,res;
while(n>0){
string result,tmp ;
cin>>str1;
cin >> str2;

l1 = str1.length();
l2 = str2.length();
if(l1>1000||l2>1000){
cout<<"0 + 0 = 0"<<endl;
continue;
}

if(l1>=l2){
large = str1;
small = str2;
}else{
large = str2;
small = str1;
}
l1 = large.length();
l2 = small.length();
for (int i = (int)(l2-1), j =(int)(l1-1); i >=0; i--,j--) {
xs = small[i] - '0';
xl = large[j] - '0';
if(count == 0)
res = xs + xl;
else{
res = xs + xl +count;
count = 0;
}
if(res > 9){
res = res % 10;
count = 1;
}
tmp = res + '0';
result = tmp + result;
}
for (int i = (int)(l1-l2-1); i >=0; i--) {
if(count == 0){
result = large[i] + result;
}
else{
xl = large[i] - '0';
res = xl +count;
count = 0;
if(res > 9){
res = res % 10;
count = 1;
}
tmp = res + '0';
result = tmp + result;
}
}
if(count==1) {
tmp = count + '0';
result = tmp + result;
}
cout<<"Case "<<k<<":"<<endl;

cout<<str1<<" "<<"+"<<" "<<str2<<" "<<"="<<" "<<result<<endl;
if(k<number)
cout<<endl;

k++;
n--;
result = "";
count = 0;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: