您的位置:首页 > 其它

hdu 5407 CRB and Candies(数论,LCM,快速幂取模,求逆元)

2016-06-13 19:38 597 查看


CRB and Candies

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 947 Accepted Submission(s): 442



Problem Description

CRB has N different
candies. He is going to eat K candies.

He wonders how many combinations he can select.

Can you answer his question for all K(0
≤ K ≤ N)?

CRB is too hungry to check all of your answers one by one, so he only asks least common multiple(LCM) of all answers.

Input

There are multiple test cases. The first line of input contains an integer T,
indicating the number of test cases. For each test case there is one line containing a single integer N.

1 ≤ T ≤
300

1 ≤ N ≤ 106

Output

For each test case, output a single integer – LCM modulo 1000000007(109+7).

Sample Input

5
1
2
3
4
5


Sample Output

1
2
3
12
10


题意:求LCM(C(0,n),C(1,n)...,C(n,n))

思路:我也不知道怎么来的公式反正直接用就是了。证明过程来自 http://arxiv.org/pdf/0906.2295v2.pdf 因为是英文的能看懂就看吧

结论就是:

令an=LCM(C(n,0),C(n,1),C(n,2),...,C(n,n))

bn=LCM(1,2,3,...,n)

an=bn+1n+1

if (n=pk)bn=p∗bn−1elsebn=bn−1

所以用素数筛选求出所有n可由单个质因子累乘的数即可。然后用欧拉定理或者乘法逆元求n+1的逆元

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 1000100
#define LL long long
LL mod=1000000007;
LL notprime
,prime
;
LL dp
;
void init()
{
for(LL i=2; i*i<N; i++)
{
if(!notprime[i])
{
for(LL j=i; j<N; j*=i)
prime[j]=i;
for(LL j=i*i; j<N; j+=i)
notprime[j]=1;
}
}
dp[1]=1;
for(int i=2; i<=N; i++)
if(prime[i])
dp[i]=dp[i-1]*prime[i]%mod;
else if(!notprime[i]) dp[i]=dp[i-1]*i%mod;
else dp[i]=dp[i-1];
}
LL pow_mod(LL a,LL n)
{
LL ans=1;
while(n)
{
if(n&1) ans=ans*a%mod;
a=a*a%mod;
n>>=1;
}
return ans;
}
LL inv(LL n)
{
return pow_mod(n,mod-2);
}
int main()
{
int T;
LL n;
init();
scanf("%d",&T);
while(T--)
{
scanf("%lld",&n);
LL ans=dp[n+1]*inv(n+1)%mod;
printf("%lld\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: