您的位置:首页 > 其它

NYOJ 587 blockhouses (DFS)

2016-06-12 14:10 239 查看
题目587

题目信息

运行结果

本题排行

讨论区




blockhouses

时间限制:1000 ms  |  内存限制:65535 KB
难度:3

描述Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical
column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations.
For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 

输入The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of
the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.
输出For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
样例输入
4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0


样例输出
5
1
5
2
4


来源
2012年10月份月赛(高年级组)

#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn = 5;
int n;
int ans, max1;
char map[maxn][maxn];
bool vis[maxn][maxn];

int check(int r, int c)
{
for (int i = c; map[r][i] != 'X' && i >= 0; i--){   //向左(遇到墙就停止)
if (map[r][i] == '#')    //如果同一行存在炮台
return 0;
}
for (int i = r; map[i][c] != 'X' && i >= 0; i--){   //向上(遇到墙就停止)
if (map[i][c] == '#')    //如果同一列存在炮台
return 0;
}
return 1;
}

void dfs(int pos, int sum)   //pos是将二维数组当做一位数组来处理(1.。。。。n*n),sum是已经放置炮台的个数
{
int r = pos / n;    //行
int c = pos % n;    //列
if (pos == n * n){    //如果所有的点都走了一遍(边界条件)
if (sum > max1)
max1 = sum;
return;
}
if (map[r][c] == '.'){
if (check(r, c)){    //检查该点建炮台是否冲突
map[r][c] = '#';   //标志该点建了炮台
dfs(pos + 1, sum + 1);
map[r][c] = '.';     //恢复到原来的样子
}
}
dfs(pos + 1, sum);   //如果不符合条件
}

int main()
{
while (cin >> n, n){
memset(map, 0, sizeof(map));
for (int i = 0; i < n; i++){
cin >> map[i];
}
max1 = -1;
dfs(0, 0);
cout << max1 << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: