您的位置:首页 > 其它

Poj487-3279

2016-06-11 20:36 274 查看
Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of
the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza
Hut by calling their ``three tens'' number 3-10-10-10. 

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

A, B, and C map to 2 

D, E, and F map to 3 

G, H, and I map to 4 

J, K, and L map to 5 

M, N, and O map to 6 

P, R, and S map to 7 

T, U, and V map to 8 

W, X, and Y map to 9 

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number
alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange
the output lines by telephone number in ascending lexicographical order. If there
4000
are no duplicates in the input print the line: 

No duplicates. 

Sample Input
12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output
310-1010 2
487-3279 4
888-4567 3
思路:
1.获取输入,使用Scanner。
2.对输入内容逐行进行处理,处理成标准数字格式。使用查表法。
3.利用TreeMap<String,Integer>保存处理过的内容,并记录出现次数。
4.输出键与键对应的值。
代码如下:
import java.io.IOException;
import java.util.Map;
import java.util.Map.Entry;
import java.util.Scanner;
import java.util.Set;
import java.util.TreeMap;
/**
 *487-3279算法实现
 *@author wangxnp
 *@email
 *@date
 */
class PhoneNumber
{
//数字字母映射表
public final static char dMap[]={'2','2','2','3','3','3',
                            '4','4','4','5','5','5',
                            '6','6','6','7','Q','7','7',
                            '8','8','8','9','9','9','Z'};
public static void main(String[] args)
{
Scanner scanner=new Scanner(System.in);
int totalNum=Integer.parseInt(scanner.nextLine());
int count=0;
Map<String,Integer>phoneMap=new TreeMap<String,Integer>();
//将号码录入,并统计
while(count++<totalNum)
{
String phone=scanner.nextLine();
phone=phone.replaceAll("-","").trim();
String phoneNum=getPhoneNum(phone);  //获取的标准电话格式
Integer timeCount=phoneMap.get(phoneNum);
timeCount=timeCount==null?0:timeCount;
phoneMap.put(phoneNum,timeCount+1);
}
//输出
Set<Entry<String,Integer>>phoneMapEntries=phoneMap.entrySet();
boolean flag=false;
for(Entry<String,Integer>entry:phoneMapEntries)
{
if(entry.getValue()>1)
{
System.out.println(entry.getKey()+" "+entry.getValue());
flag=true;
}
}
if(!flag)
{
System.out.println("No duplicates.");
}
}
//获取标准电话格式
private static String getPhoneNum(String phone)
{
char[]phoneArr=new char[phone.length()+1];
for(int i=0;i<phoneArr.length;i++)
{
if(i==3)
{
phoneArr[i++]='-';
}
if(i<3)
{
phoneArr[i]=getNum(phone.charAt(i));
}
else
{
phoneArr[i]=getNum(phone.charAt(i-1));
}

}
return new String(phoneArr);

}
//字母数字映射,通过查表法得到。
private static char getNum(char c)
{
if(c>='A'&&c<='Z')
{
return dMap[c-'A'];
}
return c;
}
}
总结:
1.熟练掌握TreeMap类的添加与输出操作。
2.查表法的应用。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: