您的位置:首页 > 其它

HDU 2141 Can you find it? (二分)

2016-06-11 13:23 337 查看
[align=left]Problem Description[/align]
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

 

[align=left]Input[/align]
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent
the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

 

[align=left]Output[/align]
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".

 

[align=left]Sample Input[/align]

3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10

 

[align=left]Sample Output[/align]

Case 1:
NO
YES
NO

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define N 505
int a
, b
, c
, ab[N * N], x;
int la, lb, lc, lab, lx;
int main()
{
int cnt = 0;
while (~scanf("%d%d%d", &la, &lb, &lc))
{
cnt++; printf("Case %d:\n", cnt);
for (int i = 1; i <= la; i++) scanf("%d", &a[i]);
for (int i = 1; i <= lb; i++) scanf("%d", &b[i]);
for (int i = 1; i <= lc; i++) scanf("%d", &c[i]);
lab = 0;
for (int i = 1; i <= la; i++)
for (int j = 1; j <= lb; j++)
ab[++lab] = a[i] + b[j];
sort(ab + 1, ab + 1 + lab);
lab = unique(ab + 1, ab + 1 + lab) - ab;
scanf("%d", &lx);
for (int i = 1; i <= lx; i++)
{
scanf("%d", &x);
int j;
for (j = 1; j <= lc; j++)
{
int key = x - c[j];
if (*lower_bound(ab + 1, ab + 1 + lab, key) == key)	break;
}
if (j <= lc) printf("YES\n");
else printf("NO\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: