您的位置:首页 > 其它

【lightoj】-1294 Positive Negative Sign

2016-06-10 11:43 387 查看
Positive Negative Sign

ime Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit Status

Description

Given two integers: n and m and n is divisible by 2m, you have to write down the first n natural numbers in the following form. At first take first m integers
and make their sign negative, then take next m integers and make their sign positive, the next m integers should have negative signs and continue this procedure until all the nintegers have been assigned a
sign. For example, let n be 12 and m be 3. Then we have

-1 -2 -3 +4 +5 +6 -7 -8 -9 +10 +11 +12

If n = 4 and m = 1, then we have

-1 +2 -3 +4

Now your task is to find the summation of the numbers considering their signs.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing two integers: n and m (2 ≤ n ≤ 109, 1 ≤ m). And you can assume that nis divisible by 2*m.

Output

For each case, print the case number and the summation.

Sample Input

2

12 3

4 1

Sample Output

Case 1: 18

Case 2: 2

这道题真的是一个忧伤的故事!!!呜呜,wa了六次,因为没有好好看题,虽然想多了吧,但是类型用的不对啊!!!看题啊!!!!

#include<cstdio>
int main()
{
int t;
int j=1;
scanf("%d",&t);
while(t--)
{
long long n,m,y;
long long z=0;
scanf("%lld%lld",&n,&m);
y=n/m;
z=m*m*(y/2);
printf("Case %d: %lld\n",j,z);
j++;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: