您的位置:首页 > 其它

POJ 3974 Palindrome manacher

2016-06-09 21:23 253 查看
题目链接:HDU3974

Palindrome

Time Limit: 15000MS Memory Limit: 65536K
Total Submissions: 7002 Accepted: 2596
Description

Andy the smart computer science student was attending an algorithms class when the professor asked the students a simple question, "Can you propose an efficient algorithm to find the length of the largest palindrome in a string?" 

A string is said to be a palindrome if it reads the same both forwards and backwards, for example "madam" is a palindrome while "acm" is not. 

The students recognized that this is a classical problem but couldn't come up with a solution better than iterating over all substrings and checking whether they are palindrome or not, obviously this algorithm is not efficient at all, after a while Andy raised
his hand and said "Okay, I've a better algorithm" and before he starts to explain his idea he stopped for a moment and then said "Well, I've an even better algorithm!". 

If you think you know Andy's final solution then prove it! Given a string of at most 1000000 characters find and print the length of the largest palindrome inside this string.
Input

Your program will be tested on at most 30 test cases, each test case is given as a string of at most 1000000 lowercase characters on a line by itself. The input is terminated by a line that starts with the string "END" (quotes for clarity). 

Output

For each test case in the input print the test case number and the length of the largest palindrome. 

Sample Input
abcbabcbabcba
abacacbaaaab
END

Sample Output
Case 1: 13
Case 2: 6


题意:问最长的回文串的长度。
题目分析:相当裸的manacher模板,注意判断结束输入的条件。

//
// main.cpp
// POJ3974
//
// Created by teddywang on 16/6/9.
// Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char s[2000010];
int p[2000010];
int main()
{
int kase=1;
while(scanf("%s",s))
{
int len=strlen(s);
if(len==3&&strcmp(s,"END")==0) break;
for(int i=len;i>=0;i--)
{
s[2*i+2]=s[i];
s[2*i+1]='#';
}
s[0]='*';
int id=0,maxlen=0,maxn=0;
for(int i=2;i<2*len+1;i++)
{
maxlen=id+p[id]-1;
if(maxlen>i-1) p[i]=min(p[2*id-i],maxlen-i+1);
else p[i]=1;
while(s[i+p[i]]==s[i-p[i]]) p[i]++;
if(p[i]+i>p[id]+id) id=i;
maxn=max(p[i],maxn);
}
printf("Case %d: %d\n",kase++,maxn-1);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: