您的位置:首页 > 其它

UVa 10763

2016-06-07 17:23 197 查看
A - Foreign Exchange
Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld & %llu

Description

Your non-profit organization (iCORE - international Confederation of Revolver Enthusiasts) coordinates a very successful foreign student exchange
program. Over the last few years, demand has sky-rocketed and now you need assistance with your task.

The program your organization runs works as follows: All candidates are asked for their original location and the location they would like to go to. The program works out only if every student has a suitable exchange partner.
In other words, if a student wants to go from A to B, there must be another student who wants to go from B to A. This was an easy task when there were only about 50 candidates, however now there are up to 500000 candidates!

Input

The input file contains multiple cases. Each test case will consist of a line containing n - the number of candidates (1≤n≤500000), followed by n lines representing the exchange
information for each candidate. Each of these lines will contain 2 integers, separated by a single space, representing the candidate's original location and the candidate's target location respectively. Locations will be represented by nonnegative
integer numbers. You may assume that no candidate will have his or her original location being the same as his or her target location as this would fall into the domestic exchange program. The input is terminated by a case where n = 0; this
case should not be processed.

Output

For each test case, print "YES" on a single line if there is a way for the exchange program to work out, otherwise print "NO".

Sample Input

10

1 2

2 1

3 4

4 3

100 200

200 100

57 22

22 57

1 2

2 1

10

1 2

3 4

5 6

7 8

9 10

11 12

13 14

15 16

17 18

19 20

0


Sample Output

YES

NO


#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>

using namespace std;

int main()
{
int n;
while(cin>>n&&n){
int ans=0;
map<string,int> a;
while(n--){
int x,y;
cin>>x>>y;
if(x>y) swap(x,y);
string str;
char temp[10]={0};
sprintf(temp,"%d",x);
str+=(string)temp;
str+=',';
memset(temp,0,sizeof(0));
sprintf(temp,"%d",y);
str+=(string)temp;
if(a[str]){
ans--;
a[str]--;
}else{
a[str]++;
ans++;
}
}
if(ans) cout<<"NO"<<endl;
else cout<<"YES"<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: