您的位置:首页 > 编程语言 > PHP开发

HDOJ 1091 A+B for Input-Output Practice (III)

2016-06-07 16:55 691 查看
Problem Description

Your task is to Calculate a + b.

 

Input

Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.

 

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input. 

 

Sample Input

1 5
10 20
0 0

 

Sample Output

6
30

 

Author

lcy

虽然是水题,第一遍做的时候竟然WA了,那就把错误的代码拿出来大家也留意。。。

#include <iostream>
using namespace std;

int main()
{
int a,b;
while((cin>>a>>b)&&(a!=0&&b!=0))
cout << a+b << endl;
return 0;
}


运行后发现输入0和一个非0数的时候,程序结束。认真想了想,逻辑有问题,改了后果断AC。
#include <iostream>
using namespace std;

int main()
{
int a,b;
while((cin>>a>>b)&&(a!=0||b!=0))
cout << a+b << endl;
return 0;
}


Problem Description

Your task is to Calculate a + b.

 

Input

Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.

 

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input. 

 

Sample Input

1 5
10 20
0 0

 

Sample Output

6
30

 

Author

lcy
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: