您的位置:首页 > 其它

HDU-1398 Square Coins(生成函数)

2016-06-07 14:47 465 查看
跳转到题目


Square Coins

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)



Problem Description

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are
available in Silverland.

There are four combinations of coins to pay ten credits:

ten 1-credit coins,

one 4-credit coin and six 1-credit coins,

two 4-credit coins and two 1-credit coins, and

one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.

Sample Input

2
10
30
0


Sample Output

1
4
27


第一反映还是完全背包,觉得这类型的生成函数还是没有那种意识

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int MAXN=305;

int n;
int a[MAXN],t[MAXN],coin[19];//a[i]表示x^i的系数,即凑成数i的方案数

void init() {
for(int i=0;i<=17;++i) {
coin[i]=i*i;
}
for(int i=0;i<MAXN;++i) {//初始化第一个表达式 (1+x+x^2+…+x^n),系数均为1
a[i]=1;
t[i]=0;
}
for(int i=2;i<=17;++i) {//遍历第i个表达式 (1+x^i+x^(2*i)+…)
for(int j=0;j<MAXN;++j) {//遍历前i-1个表达式乘积展开的表达式的x^j的系数
for(int k=j;k<=MAXN;k+=coin[i]) {//遍历前i个表达式乘积展开的表达式的x^k的系数
t[k]+=a[j];
}
}
for(int j=0;j<MAXN;++j) {//得到前i个表达式展开的系数
a[j]=t[j];
t[j]=0;
}
}
}

int main() {
init();
while(scanf("%d",&n),n!=0) {
printf("%d\n",a
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  生成函数