您的位置:首页 > 其它

HDU--2052 picture

2016-06-07 13:07 211 查看


Picture

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 23172    Accepted Submission(s): 11813


[align=left]Problem Description[/align]
Give you the width and height of the rectangle,darw it.
 

[align=left]Input[/align]
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
 

[align=left]Output[/align]
For each case,you should draw a rectangle with the width and height giving in the input.

after each case, you should a blank line.
 

[align=left]Sample Input[/align]

3 2

 

[align=left]Sample Output[/align]

+---+
| |
| |
+---+代码:
#include<stdio.h>
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(int i=1;i<=m+2;i++)
{
if(i==1||i==m+2)
{
printf("+");
for(int j=2;j<n+2;j++)
printf("-");
printf("+\n");
}
else
{
printf("|");
for(int j=2;j<n+2;j++)
{
printf(" ");
}
printf("|\n");
}
}
printf("\n");
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  水题