您的位置:首页 > 其它

hdu 1563 Find your present!

2016-06-05 13:28 441 查看

Find your present!

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3579 Accepted Submission(s): 2386

[align=left]Problem Description[/align]
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.

[align=left]Input[/align]
The input file will consist of several cases. Each case will be presented by an integer n (1<=n<=200, and n is odd) at first. Following that, n positive integers will be given in a line. These numbers indicate the card numbers of the presents.n = 0 ends the input.

[align=left]Output[/align]
For each case, output an integer in a line, which is the card number of your present.

[align=left]Sample Input[/align]

5
1 1 3 2 2
3
1 2 1
0

[align=left]Sample Output[/align]

3
2
位运算:

#include <iostream>
using namespace std;

int main(){
int n, num;
while(cin >> n && n != 0){
int ans = 0;
for(int i = 0; i < n; i++){
cin >> num;
ans = ans ^ num;
}
cout << ans << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: