您的位置:首页 > 其它

hdu 1570 AC

2016-06-05 13:19 211 查看

A C

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4830 Accepted Submission(s): 3115

[align=left]Problem Description[/align]
Are you excited when you see the title "AC" ? If the answer is YES , AC it ;
You must learn these two combination formulas in the school . If you have forgotten it , see the picture.



Now I will give you n and m , and your task is to calculate the answer .

[align=left]Input[/align]
In the first line , there is a integer T indicates the number of test cases. Then T cases follows in the T lines. Each case contains a character 'A' or 'C', two integers represent n and m. (1<=n,m<=10)

[align=left]Output[/align]
For each case , if the character is 'A' , calculate A(m,n),and if the character is 'C' , calculate C(m,n). And print the answer in a single line.

[align=left]Sample Input[/align]

2

A 10 10
C 4 2

[align=left]Sample Output[/align]

3628800
6

#include <iostream>
using namespace std;
int f[11] = {1, 1};

int main(){
for(int i = 2; i < 11; i++){
f[i] = i * f[i-1];
}
int test, n, m;
char c;
cin >> test;
while(test--){
cin >> c >> n >> m;
if(c == 'A')
cout << f
/ f[n - m] << endl;
else if(c == 'C')
cout << f
/ f[m] / f[n - m] << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: