您的位置:首页 > 其它

1097. Deduplication on a Linked List (25)

2016-06-05 12:17 351 查看
Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean
time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (<= 105) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 104, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 5

99999 -7 87654

23854 -15 00000

87654 15 -1

00000 -15 99999

00100 21 23854

Sample Output:

00100 21 23854

23854 -15 99999

99999 -7 -1

00000 -15 87654
87654 15 -1

IDEA

1.vector[p]表示下标p表示该节点的地址,节点信息包括其val,和next地址信息

2.遍历链表,判断是否为重复的,记录其首地址和修改下一个地址(地址的链接)

3.在原vec中修改,然后遍历各自首地址等,输出信息



CODE

#include<iostream>
#include<cstdio>
#include<vector>
#include<cmath>
#include<fstream>
using namespace std;
#define MAX 100010
struct Node{
int val;
int next;
};
int main(){
#ifndef ONLINE_JUDGE
freopen("input.txt","r",stdin);
#endif

int start,n;
cin>>start>>n;
vector<Node> vec(MAX);
for(int i=0;i<n;i++){
int address;
Node node;
cin>>address>>node.val>>node.next;
vec[address]=node;
}

int count[MAX]={0};
int p=start;
int main_pre=-1,f1=-1;
int sub_pre=-1,f2=-1;
while(p!=-1){
int num=abs(vec[p].val);
count[num]++;
if(count[num]>1){
if(f2==-1){
f2=sub_pre=p;
}else{
sub_pre=vec[sub_pre].next=p;
}
}else{
if(f1==-1){
f1=main_pre=p;
//cout<<"p1:"<<f1<<endl;
}else{
main_pre=vec[main_pre].next=p;
}
}
p=vec[p].next;
}
vec[main_pre].next=-1;
p=f1;
//cout<<p<<endl;
while(p!=-1){
printf("%05d %d ",p,vec[p].val);
if(vec[p].next==-1){
printf("-1\n");
}else{
printf("%05d\n",vec[p].next);
}
p=vec[p].next;
}

// if(f2!=-1){
// vec[sub_pre].next=-1;
// }
vec[sub_pre].next=-1;
p=f2;
while(p!=-1){
printf("%05d %d ",p,vec[p].val);
if(vec[p].next==-1){
printf("-1\n");
}else{
printf("%05d\n",vec[p].next);
}
p=vec[p].next;
}

#ifndef ONLINE_JUDGE
fclose(stdin);
#endif
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息