您的位置:首页 > 其它

hdoj-4245-A Famous Music Composer

2016-06-04 21:42 411 查看
Problem Description

Mr. B is a famous music composer. One of his most famous work was his set of preludes. These 24 pieces span the 24 musical keys (there are musically distinct 12 scale notes, and each may use major or minor tonality). The 12 distinct scale notes are:



Five of the notes have two alternate names, as is indicated above with equals sign. Thus, there are 17 possible names of scale notes, but only 12 musically distinct notes. When using one of these as the keynote for a musical key, we can further distinguish between major and minor tonalities. This gives 34 possible keys, of which 24 are musically distinct.



In naming his preludes, Mr. B used all the keys except the following 10, which were named instead by their alternate names:

Write a program that, given the name of a key, give an alternate name if it has one, or report the key name is unique.

Input

Each test case is described by one line having the format “note tonality”, where “note” is one of the 17 names for the scale notes given above, and “tonality” is either “major” or “minor” (quotes for clarify).

Output

For each case output the required answer, following the format of the sample.

Sample Input

Ab minor

D# major

G minor

Sample Output

Case 1: G# minor

Case 2: Eb major

Case 3: UNIQUE

题目看了半天,看懂之后就是枚举转化一下就好了

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

int main()
{
char s1[100],s2[100];
int  cas=1;
while(scanf("%s%s",s1,s2)!=EOF)
{
printf("Case %d: ",cas);
cas++;
if(strcmp(s1,"A#")==0)
printf("Bb %s\n",s2);
else if(strcmp(s1,"Bb")==0)
printf("A# %s\n",s2);
else if(strcmp(s1,"C#")==0)
printf("Db %s\n",s2);
else if(strcmp(s1,"Db")==0)
printf("C# %s\n",s2);
else if(strcmp(s1,"D#")==0)
printf("Eb %s\n",s2);
else if(strcmp(s1,"Eb")==0)
printf("D# %s\n",s2);
else if(strcmp(s1,"Gb")==0)
printf("F# %s\n",s2);
else if(strcmp(s1,"F#")==0)
printf("Gb %s\n",s2);
else if(strcmp(s1,"G#")==0)
printf("Ab %s\n",s2);
else if(strcmp(s1,"Ab")==0)
printf("G# %s\n",s2);
else printf("UNIQUE\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: