您的位置:首页 > 其它

正数负数分段求和

2016-06-03 23:15 253 查看
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit Status

Description

Given two integers: n and m and n is divisible by 2m, you have to write down the first n natural numbers in the following form. At first take first mintegers
and make their sign negative, then take next m integers and make their sign positive, the next m integers should have negative signs and continue this procedure until all the n integers have been assigned
a sign. For example, let n be 12 and m be 3. Then we have

-1 -2 -3 +4 +5 +6 -7 -8 -9 +10 +11 +12

If n = 4 and m = 1, then we have

-1 +2 -3 +4

Now your task is to find the summation of the numbers considering their signs.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing two integers: n and m (2 ≤ n ≤ 109, 1 ≤ m). And you can assume that n is divisible by 2*m.

Output

For each case, print the case number and the summation.

Sample Input

2

12 3

4 1

Sample Output

Case 1: 18

Case 2: 2

解题思路:

这道题刚开始想复杂了,n能被2m整除说明它可以分成n/2m个正负段。每一个正负段的和为m*m;所以输出m*n/2就行了!
注意要用long long型。
代码:
#include<stdio.h>

int main()

{
int t,k=1;
long long n,m;
scanf("%d",&t);
while(t--)
{
  scanf("%lld%lld",&n,&m);
  printf("Case %d: %lld\n",k++,n*m/2);
}
return 0;

 } 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: