您的位置:首页 > 其它

hdu2639-01背包

2016-06-03 22:16 260 查看

Bone Collector II

Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3834 Accepted Submission(s): 1985

Problem Description

The title of this problem is familiar,isn’t it?yeah,if you had took part in the “Rookie Cup” competition,you must have seem this title.If you haven’t seen it before,it doesn’t matter,I will give you a link:

Here is the link:http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.

Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the K-th maximum of the total value (this number will be less than 231).

Sample Input

3

5 10 2

1 2 3 4 5

5 4 3 2 1

5 10 12

1 2 3 4 5

5 4 3 2 1

5 10 16

1 2 3 4 5

5 4 3 2 1

Sample Output

12

2

0

Author

teddy

Source

百万秦关终属楚

01背包,算的过程中记录加骨头的过程,记录增值。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int vol[1010],val[1010],dp[1010][31],a[31],b[31];
int main(){
int t,n,v,i,j,k;
//freopen("in.txt","r",stdin);
while(scanf("%d",&t)!=EOF){
while(t--){
memset(dp,0,sizeof(dp));
scanf("%d%d%d",&n,&v,&k);
for ( i = 0; i < n; ++i)
{
scanf("%d",&val[i]);
}
for ( i = 0; i < n; ++i)
{
scanf("%d",&vol[i]);
}

for ( i = 0; i < n; ++i)
{
for ( j = v; j >=vol[i]; j--)
{
int d;
for ( d = 1; d <= k; ++d)
{
a[d]=dp[j-vol[i]][d]+val[i];
b[d]=dp[j][d];
}
int x=1,y=1,z=1;
a[d]=b[d]=-1;
while(z<=k&&(x<=k||y<=k)){
if(a[x]>b[y]){
dp[j][z]=a[x];
x++;
}else{
dp[j][z]=b[y];
y++;
}
if(dp[j][z]!=dp[j][z-1])
z++;
}

//dp[j]=max(dp[j],dp[j-vol[i]]+val[i]);
}
}
printf("%d\n",dp[v][k]);
/*          if(k!=1)printf("0\n");
else
printf("%d\n", dp[i]);  */
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  01背包