您的位置:首页 > 其它

hdu 2602 Bone Collector (01背包)

2016-06-03 10:38 369 查看
[align=left]Problem Description[/align]
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?



[align=left]Input[/align]
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

[align=left]Output[/align]
One integer per line representing the maximum of the total value (this number will be less than 231).

[align=left]Sample Input[/align]

1
5 10
1 2 3 4 5
5 4 3 2 1

[align=left]Sample Output[/align]

14

//最简单的01背包问题

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

int main()
{
int t,n,v;
int value[1005],volume[1005],dp[1005];
cin>>t;
while(t--)
{
cin>>n>>v;
for(int i=1;i<=n;i++)
cin>>value[i];
for(int j=1;j<=n;j++)
cin>>volume[j];
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
for(int j=v;j>=volume[i];j--)
dp[j]=max(dp[j],dp[j-volume[i]]+value[i]);
cout<<dp[v]<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: