您的位置:首页 > 其它

hdoj-5704-Luck Competition

2016-06-02 20:11 393 查看
[align=left]Problem Description[/align]
Participants of the Luck Competition choose a non-negative integer no more than 100 in their mind. After choosing their number, let
K
be the average of all numbers, and M
be the result of K×23.
Then the lucky person is the one who choose the highest number no more than
M.
If there are several such people, the lucky person is chosen randomly.

If you are given a chance to know how many people are participating the competition and what their numbers are, calculate the highest number with the highest probability to win assuming that you're joining the competition.

 

[align=left]Input[/align]
There are several test cases and the first line contains the number of test cases
T(T≤10).

Each test case begins with an integer N(1<N≤100),
denoting the number of participants. And next line contains
N−1
numbers representing the numbers chosen by other participants.

 

[align=left]Output[/align]
For each test case, output an integer which you have chosen and the probability of winning (round to two digits after the decimal point), seperated by space.

 

[align=left]Sample Input[/align]

3
4
1 2 3
4
1 1 2
4
20 30 40

 

[align=left]Sample Output[/align]

1 0.50
0 1.00
18 1.00

 

简单数学题啊,妈个鸡,想了

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
const int N = 105;
const int M = 15;
int c
;
int main()
{
int t,n,i,sum,x;
scanf("%d",&t);
while(t--)
{
sum=0;
memset(c,0,sizeof(c));
scanf("%d",&n);
for(i=1;i<n;i++)
{
scanf("%d",&x);
c[x]++;
sum+=x;
}
x=2*sum/(3*n-2);
printf("%d %.2f\n",x,1.0/(c[x]+1));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: