您的位置:首页 > 其它

UVA oj 490 Rotating Sentences(字符串)

2016-06-02 00:00 274 查看
Rotating Sentences

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu
Submit Status

Description





In ``Rotating Sentences,'' you are asked to rotate a series of input sentences 90 degrees clockwise. So instead of displaying the input sentences from left to right and top to bottom, your program will display them from top to
bottom and right to left.

Input and
Output

As input to your program, you will be given a maximum of 100 sentences, each not exceeding 100 characters long. Legal characters include: newline, space, any punctuation characters, digits, and lower case or upper case English
letters. (NOTE: Tabs are not legal characters.)

The output of the program should have the last sentence printed out vertically in the leftmost column; the first sentence of the input would subsequently end up at the rightmost column.

Sample Input

Rene Decartes once said,
"I think, therefore I am."


Sample Output

"R
Ie
n
te
h
iD
ne
kc
,a
r
tt
he
es
r
eo
fn
oc
re
e
s
Ia
i
ad
m,
.
"

这题就是把输入字符串顺时针旋转90度,没有字符的地方用空格补齐,不用文件的输入输出的话看不到测试结果

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

const int maxn = 105;
char a[maxn][maxn];

int main()
{
int maxlen = -1;
int i = 0;
memset(a,0,sizeof(a));
freopen("in.txt","r",stdin);
freopen("out.txt","w",stdout);
while(gets(a[i]))
{
int len = strlen(a[i]);
if(maxlen < len)
maxlen = len;
i++;
}
for(int j=0;j<maxlen;j++)
{
for(int k=i-1;k>=0;k--)
{
if(a[k][j] == 0)
printf(" ");
else
printf("%c",a[k][j]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  UVAoj490 字符串