您的位置:首页 > 其它

HDU 3711 D - Binary Number

2016-06-01 22:22 246 查看
Description

For 2 non-negative integers x and y, f(x, y) is defined as the number of different bits in the binary format of x and y. For example, f(2, 3)=1,f(0, 3)=2, f(5, 10)=4. Now given 2 sets of non-negative integers A and B, for each integer b in B, you should find an integer a in A such that f(a, b) is minimized. If there are more than one such integer in set A, choose the smallest one.

Input

The first line of the input is an integer T (0 < T ≤ 100), indicating the number of test cases. The first line of each test case contains 2 positive integers m and n (0 < m, n ≤ 100), indicating the numbers of integers of the 2 sets A and B, respectively. Then follow (m + n) lines, each of which contains a non-negative integers no larger than 1000000. The first m lines are the integers in set A and the other n lines are the integers in set B.

Output

For each test case you should output n lines, each of which contains the result for each query in a single line.

Sample Input

2

2 5

1

2

1

2

3

4

5

5 2

1000000

9999

1423

3421

0

13245

353

Sample Output

1

2

1

1

1

9999

0

在A里面找到一个数使得它和B里面的数二进制化时不一样的位数最大,如果有多个答案,取最小值,模拟。

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
int a[105];
int count(int a)
{
int ans = 0;
for(;a;a>>=1) if(a&1) ans++;
printf("ans=%d\n",ans);
return ans;
}
int main()
{
int b, i, j, n, m, k, minn, t,cas;
scanf("%d",&cas);
while(cas--)
{
scanf("%d%d",&n,&m);
for(i=0; i<n; i++)
scanf("%d",&a[i]);
for(i=0; i<m; i++)
{
scanf("%d",&b);
minn = count(b^a[0]);
k = 0;
for(j=1; j<n; j++)
{
t = count(b^a[j]);
if(t<minn||t==minn&&a[j]<a[k])
{ minn = t;k = j;}
}
printf("%d\n",a[k]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU-3711