您的位置:首页 > 其它

hdu5676 ztr loves lucky numbers (打表二分)

2016-06-01 20:14 435 查看
ztr loves lucky numbers

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1132 Accepted Submission(s): 478

Problem Description

ztr loves lucky numbers. Everybody knows that positive integers are lucky if their decimal representation doesn’t contain digits other than 4 and 7. For example, numbers 47, 744, 4 are lucky and 5, 17, 467 are not.

Lucky number is super lucky if it’s decimal representation contains equal amount of digits 4 and 7. For example, numbers 47, 7744, 474477 are super lucky and 4, 744, 467 are not.

One day ztr came across a positive integer n. Help him to find the least super lucky number which is not less than n.

Input

There are T(1≤n≤105) cases

For each cases:

The only line contains a positive integer n(1≤n≤1018). This number doesn’t have leading zeroes.

Output

For each cases

Output the answer

Sample Input

2

4500

47

Sample Output

4747

47

#include<cstdio>
#include<algorithm>
#include<cmath>
#include<vector>
#include<iostream>
using namespace std;

typedef long long ll;

int bit(ll num){
return log10(num)+1;
}
vector<ll> vec;

bool judge(ll num){
int l4=0,l7=0;
while(num){
if(num%10==4){
++l4;
}else if(num%10==7){
++l7;
}else return false;
num/=10;
}
return l4==l7;
}
void dfs(ll num){
if(num&&judge(num))vec.push_back(num);
if(bit(num)<18){
ll nums=num*10+4;
dfs(nums);
nums=num*10+7;
dfs(nums);
}
}

int main(){
int T;
ll uu=19923;

vec.clear();
dfs(0LL);
sort(vec.begin(),vec.end());
scanf("%d",&T);
int len=vec.end()-vec.begin();
while(T--){
ll n;
scanf("%lld",&n);
int pos=upper_bound(vec.begin(),vec.end(),n)-vec.begin();

if(pos==len){
printf("44444444447777777777\n");
}else{
printf("%lld\n",vec[pos]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: