您的位置:首页 > 其它

POJ 3249 Test for Job【DAG图上的最短路问题】

2016-06-01 20:09 309 查看
Test for Job
Time Limit: 5000MS

 

Memory Limit: 65536K

Total Submissions: 10381

 

Accepted: 2421

Description

Mr.Dog was fired by his company. In order to support his family, he must find a new job as soon as possible. Nowadays, It's hard to have a job, since there are swelling numbers of the unemployed. So some companies often use hard tests for their recruitment.

The test is like this: starting from a source-city, you may pass through some directed roads to reach another city. Each time you reach a city, you can earn some profit or pay some fee, Let this process continue until you reach a target-city. The boss will
compute the expense you spent for your trip and the profit you have just obtained. Finally, he will decide whether you can be hired.

In order to get the job, Mr.Dog managed to obtain the knowledge of the net profit Vi of all cities he may reach (a negative Vi indicates that money is spent rather than gained) and the connection between cities. A
city with no roads leading to it is a source-city and a city with no roads leading to other cities is a target-city. The mission of Mr.Dog is to start from a source-city and choose a route leading to a target-city through which he can get the maximum profit.

Input

The input file includes several test cases. 

The first line of each test case contains 2 integers n and m(1 ≤ n ≤ 100000, 0 ≤ m ≤ 1000000) indicating the number of cities and roads. 

The next n lines each contain a single integer. The ith line describes the net profit of the city i, Vi (0 ≤ |Vi| ≤ 20000) 

The next m lines each contain two integers x, y indicating that there is a road leads from city x to city y. It is guaranteed that each road appears exactly once, and there is no way to return to a previous city. 

Output

The output file contains one line for each test cases, in which contains an integer indicating the maximum profit Dog is able to obtain (or the minimum expenditure to spend)

Sample Input

6 5

1

2

2

3

3

4

1 2

1 3

2 4

3 4

5 6


Sample Output

7

Hint

Source

POJ Monthly--2007.07.08,
落叶飞雪

 

题目大意:给出n个点,m条边,每个点都提供了相对的点权值,然后给出相连着的边,问最大利润值。

 

思路:

 根据这样一句话:

A city with no roads leading to it is a source-city and a city with no roads leading to other cities is a target-city.可以判断出这个图保证是一个有向无环图(DAG图)。那么按照其拓扑排序得到的顺序来对点进行松弛就能解决DAG图上的最短路问题。

 

1、对于其多源点的问题,我们就不用多考虑了,所得到的拓扑排序的结果进行层次性的松弛,是相当于从树根一直dp到树叶的过程。 

2、对于给出的点权值,我们在初始的时候给dis【s(起点)】赋值的时候,dis【s(起点)】=val【s(起点)】即可。这样我们dis【v】=dis【u】+val【v】就相当于在求边权值的松弛了。

 

AC代码:
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int head[200005];
struct EdgeNode
{
int to;
int w;
int next;
}e[200005*20];
int vis[200007];
int val[200007];
int degree[200007];
int dis[200007];
int ans[200007];
int n,m;
int cont;
void add(int from,int to)
{
e[cont].to=to;
e[cont].next=head[from];
head[from]=cont++;
}
void DAG()
{
int cont2=0;
queue<int >s;
memset(vis,0,sizeof(vis));
for(int i=0;i<n;i++)dis[i]=-0x3f3f3f3f;
for(int i=0;i<n;i++)
{
if(degree[i]==0)
{
dis[i]=val[i];
vis[i]=1;
s.push(i);
}
}
while(!s.empty())
{
int u=s.front();
ans[cont2++]=u;
s.pop();
for(int k=head[u];k!=-1;k=e[k].next)
{
int v=e[k].to;
if(degree[v]--)
{
if(degree[v]==0&&vis[v]==0)
{
vis[v]=1;
s.push(v);
}
}
}
}
for(int i=0;i<n;i++)
{
int u=ans[i];
for(int k=head[u];k!=-1;k=e[k].next)
{
int v=e[k].to;
if(dis[v]<dis[u]+val[v])
{
dis[v]=dis[u]+val[v];
}
}
}
int output=-0x3f3f3f3f;
for(int i=0;i<n;i++)
{
if(head[i]==-1)
output=max(output,dis[i]);
}
printf("%d\n",output);
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
cont=0;
memset(degree,0,sizeof(degree));
memset(head,-1,sizeof(head));
for(int i=0;i<n;i++)
{
scanf("%d",&val[i]);
}
for(int i=0;i<m;i++)
{
int x,y;
scanf("%d%d",&x,&y);
x--;y--;
add(x,y);
degree[y]++;
}
DAG();
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ 3249 PKU 3249