您的位置:首页 > 其它

POJ2352 Stars 树状数组

2016-06-01 16:20 393 查看
Stars

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 40834 Accepted: 17783

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5

1 1

5 1

7 1

3 3

5 5

Sample Output

1

2

1

1

0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

题目大意:

有一堆(些)星星,在同一平面,按以下方法分星星的级别:

xy值都不大于它的星星的个数。

给你星星的数量和位置,输出0~n-1级星星的数量。

注:输入保证按y的大小顺序排列,y相同则比x。

思路:这题因为y递增,所以后输入的只要不比先输入的x小就等级加一,顺便用树状数组优化,不然依然超时。

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
int n,i,x,y,f[50000],ans[50000];
int count(int x){
return x&(-x);
}
int sum(int x){//求前x的和
int re=0,k=x;
while(k>0){
re+=f[k];
k-=count(k);
}
return re;
}
void pluss(int x){//累加
int k=x;
while(k<=32005){
f[k]++;
k+=count(k);
}
}
int main(){
while(scanf("%d",&n)!=EOF){
memset(f,0,sizeof(f));
memset(ans,0,sizeof(ans));
for(i=1;i<=n;i++){
scanf("%d%d",&x,&y);
x++;
ans[sum(x)]++;
pluss(x);
}
for(i=0;i<n;i++)
printf("%d\n",ans[i]);
}
return 0;
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj 题解