您的位置:首页 > 其它

18005 It is not ugly number

2016-06-01 10:18 246 查看

18005 It is not ugly number

时间限制:2000MS  内存限制:65535K
提交次数:0 通过次数:0

题型: 编程题   语言: G++;GCC

 

Description

Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ...shows the
first 10 ugly numbers. By convention, 1 is included. Then, here are the first 10 Not ugly numbers:7, 11, 13, 14, 17, 19,
21, 22, 23, 26. Given the integer n, write a program to find and print the n'th Not ugly number.




输入格式

First line is T(T<=10000), the number of cases.
The T lines following. Each line of the input contains a positive integer n (n <= 100000000).



输出格式

For each case, output the n'th Not ugly number .



 

输入样例

3
1
2
9



 

输出样例

7
11
23



 

作者

 admin

  要求第n项非丑数;无疑要先利用数学知识求出丑数。我的做法是先预处理前1200个丑数,至于为什么只用处理这个数量的丑数是自己试出来的;可能你会疑惑为什么只用处理一千多个就行了,,因为丑数是因子只含有2、3和5的数字,所以越往后面数字越大它继越有可能包含有不止这三个数的因子;所以前几百项的丑数序列看似是挺密集的,但越到后面每两个丑数间的间隔就越大。而我们要找的第n项非丑数,肯定就在某两个丑数之间。

  所以题目唯一的难点就在于求出丑数。我这里用的是优先队列来预处理。  一开始,我们知道前几项丑数:1、2、3、5;那么 如果要得出接下来同样也是因子只有2、3、5的丑数,就只需要将前面这几个已知道的丑数分别乘以2、3、5得出来的数,那它的因子同样一定是只有2、3、5的。  但是,如果将每一项都乘以这三个数的话,你会发现有重复的数字出现。因而这里要用到一个技巧:给每一个数字加多一个标记,用来标注当前这个丑数是由前面的丑数乘以哪个数字得出来的;所以用到了pair<int,int>。第一个数据域存放这个丑数的值,第二个则用来存放标记值。   比如用2分别乘以2、3、5得到4、6、10,那么得到三个pair为<4,2>、<6,3>、<10,5>;然后将这三个pair存入优先队列中去,弹出2;每次再取出最小的丑数(要从小到大取再加上刚刚说的技巧才能避免重复);假设取到pair<6,3>的时候,这时你就只能将6分别乘以3和5,而不能乘2 ( 因为前面会有<4,2>中的4乘以3得到12发生重复 )。   另外,关于得出了丑数之后再求非丑数的技巧写在了代码注释中了。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cctype>
#include <cmath>
#include <algorithm>
#include <set>
#include <map>
#include <queue>
#include <stack>
#include <utility>
#include <vector>
#define ll long long
#define inf 0x3f3f3f3f
#define MAXN 100000
using namespace std;

typedef pair<int,int> node_type;
int res[1500];
int main()
{
//freopen("input.txt","r",stdin);
priority_queue<node_type,vector<node_type>,greater<node_type> > pq;//用来存放pair的优先队列,默认是比较pair中的第一个元素,greater<>则另其每次去最小的数据
pq.push(node_type(1,2)); //压入第一个丑数
node_type temp;
for(int i=0; i<1205; i++)
{
temp=pq.top(); //取队列首,也就是当前队列中最小的丑数
switch(temp.second)  //由pair<>的第二个元素判断当前这个丑数是由哪个标记值生成的;然后继续生成新的丑数
{
case 2:
pq.push(make_pair(temp.first*2,2));
case 3:
pq.push(make_pair(temp.first*3,3));
case 5:
pq.push(make_pair(temp.first*5,5));
}
res[i]=temp.first;
pq.pop();
}
//处理完丑数后
int t,n,cnt,i;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
cnt=0;
i=0;
while(cnt<n) //cnt标记当前已寻找到的第cnt项的非丑数
{
cnt+=(res[i+1]-res[i++]-1);//cnt每次加上的值是每相邻两个丑数的差,这个差即这两个丑数之间包含的非丑数的个数
}
//找到所要的第n项非丑数在哪两个丑数之间后退出循环
i--;
cnt-=(res[i+1]-res[i]-1);//从这个丑数区间的左边开始算,res[i]加上n-cnt就是第n项丑数了
printf("%d\n",res[i]+n-cnt);
}
return 0;
}

 

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: