您的位置:首页 > 其它

POJ 2249 Binomial Showdown(排列组合)

2016-06-01 09:09 411 查看
Description

In how many ways can you choose k elements out of n elements, not taking order into account?

Write a program to compute this number.

Input

The input will contain one or more test cases.

Each test case consists of one line containing two integers n (n>=1) and k (0<=k<=n).

Input is terminated by two zeroes for n and k.

Output

For each test case, print one line containing the required number. This number will always fit into an integer, i.e. it will be less than 2 31.

Warning: Don't underestimate the problem. The result will fit into an integer - but if all intermediate results arising during the computation will also fit into an integer depends on your algorithm. The test cases will go to the limit.

Sample Input

4 2

10 5

49 6

0 0

Sample Output

6

252

13983816







#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
__int64 f[10000000];
int main()
{
__int64 n,m;
while(scanf("%I64d%I64d",&n,&m),n||m)
{
f[0]=1;
if(m>n/2)///优化不然会超时
m=n-m;
for(int i=1; i<=m; i++)
{
f[i]=f[i-1]*(n-i+1)/i;
}
printf("%I64d\n",f[m]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM 排列组合