您的位置:首页 > 其它

PAT 甲级 1027 Colors in Mars

2016-05-31 08:22 393 查看


1027. Colors in Mars (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference
is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.
Sample Input
15 43 71

Sample Output
#123456

简单题:

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <stdio.h>
#include <math.h>
#include <algorithm>
#include <vector>

using namespace std;
int a,b,c;
char aa[14]={'0','1','2','3','4','5','6','7','8','9','A','B','C','D'};
void dfs(int x,int cnt)
{
if(x<13)
{
if(cnt==0)
printf("0");
printf("%c",aa[x]);
return;
}
dfs(x/13,cnt+1);
printf("%c",aa[x%13]);
}
int main()
{
scanf("%d%d%d",&a,&b,&c);
printf("#");
dfs(a,0);
dfs(b,0);
dfs(c,0);
printf("\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: