您的位置:首页 > 其它

HDU 2612 Find a way(BFS)

2016-05-30 17:48 531 查看
Description

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.

Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.

Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.

Input

The input contains multiple test cases.

Each test case include, first two integers n, m. (2<=n,m<=200).

Next n lines, each line included m character.

‘Y’ express yifenfei initial position.

‘M’ express Merceki initial position.

‘#’ forbid road;

‘.’ Road.

‘@’ KCF

Output

For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input

4 4

Y.#@

....

.#..

@..M

4 4

Y.#@

....

.#..

@#.M

5 5

Y..@.

.#...

.#...

@..M.

#...#

Sample Output

66

88
66

题意:Y和M要在KFC约会,地图上有多个KFC,求在哪个KFC两人所走总距离最短,(注意KFC可以当做路)

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
#define INF 0x3fffffff
char map[201][202];
int vis[202][102];
int dis[202][202][2];
int f[4][2]= {0,1,1,0,-1,0,0,-1};
int n,m,flag;
struct node
{
int x,y,step;
} pose;
void bfs()
{
queue<node>Q;
node q,p;
vis[pose.x][pose.y]=1;
Q.push(pose);
while(!Q.empty())
{
q=Q.front();
Q.pop();
for(int i=0; i<4; i++)
{
p=q;
p.x+=f[i][0];
p.y+=f[i][1];

if(p.x>=0&&p.y>=0&&p.x<n&&p.y<m&&map[p.x][p.y]!='#'&&!vis[p.x][p.y])
{
vis[p.x][p.y]=1;
p.step+=11;
if(map[p.x][p.y]=='@')
dis[p.x][p.y][flag]=p.step;
Q.push(p);
}
}
}
}
int main()
{
int i,j;
while(cin>>n>>m)
{
for(i=0; i<n; i++)
for(j=0; j<m; j++)
dis[i][j][0]=dis[i][j][1]=INF;
for(i=0; i<n; i++)
for(j=0; j<m; j++)
cin>>map[i][j];
for(i=0; i<n; i++)
for(j=0; j<m; j++)
{
if(map[i][j]=='Y')
{
pose.x=i;
pose.y=j;
pose.step=0;
flag=0;
memset(vis,0,sizeof(vis));
bfs();
}
else if(map[i][j]=='M')
{
pose.x=i;
pose.y=j;
pose.step=0;
flag=1;
memset(vis,0,sizeof(vis));
bfs();
}
}
int minn=INF;
for(i=0; i<n; i++)
for(j=0; j<m; j++)
if(map[i][j]=='@'&& minn>dis[i][j][0]+dis[i][j][1])
minn=dis[i][j][0]+dis[i][j][1];
cout<<minn<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息