您的位置:首页 > Web前端

nyoj 1242 Interference Signal 第八届河南省程序设计大赛

2016-05-30 09:18 323 查看

Interference Signal

时间限制:2000 ms | 内存限制:65535 KB
难度:1

描述
Dr.Kong’s laboratory monitor some interference signals. The interference signals can be digitized into a series of positive integer. May be, there are N integers a1,a2,…,an.

Dr.Kong wants to know the average strength of a contiguous interference signal block. the block must contain at least M integers.

Please help Dr.Kong to calculate the maximum average strength, given the constraint.
输入The input contains K test cases. Each test case specifies:

* Line 1: Two space-separated integers, N and M.

* Lines2~line N+1: ai (i=1,2,…,N)

1 ≤ K≤ 8, 5 ≤ N≤ 2000, 1 ≤ M ≤ N, 0 ≤ ai ≤9999

输出For each test case generate a single line containing a single integer that is 1000 times the maximal average value. Do not perform rounding.样例输入
2


10 6


6


4


2


10


3


8


5


9


4


1


5 2


10


3


8


5


9

样例输出
6500


7333

来源第八届河南省程序设计大赛

#include<stdio.h>
int num[2005];
int main()
{
int k,n,m;
int i,j;
long long sum;
scanf("%d",&k);
while(k--)
{
scanf("%d %d",&n,&m);
for(i=0;i<n;i++)
{
scanf("%d",&num[i]);
}
int h=n-m+1;
long long c,ave=-1;
while(h--)
{
for(i=0;i<(n-m+1);i++)
{
sum=0;
for(j=i;j<m+i;j++)
{
sum+=num[j];
}
//printf(" sum %lld\n",sum);
c=sum*1000/(m*1.0);
if(ave<c) ave=c;
}
m+=1;
}

printf("%lld\n",ave);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: