您的位置:首页 > 其它

HDU 1020 Encoding 模拟

2016-05-29 17:09 405 查看

Encoding

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 39047 Accepted Submission(s): 17279


[align=left]Problem Description[/align]
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

[align=left]Input[/align]
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

[align=left]Output[/align]
For each test case, output the encoded string in a line.

[align=left]Sample Input[/align]

2
ABC
ABBCCC

[align=left]Sample Output[/align]

ABC
A2B3C
水题,直接按照题意模拟就行

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
#include<vector>
using namespace std;
struct Node
{
char a;
int num;
};
vector<Node> q;

int main()
{
int t;
scanf("%d",&t);
while(t--)
{
q.clear();
char ch[10005];
scanf("%s",ch);
int len=strlen(ch);
Node tmp;
tmp.a=ch[0];
tmp.num=1;
for(int i=1;i<len;i++)
{
if(ch[i]==tmp.a) tmp.num++;
else
{
q.push_back(tmp);
tmp.a=ch[i];
tmp.num=1;
}
}
q.push_back(tmp);
for(int i=0;i<q.size();i++)
{
if(q[i].num>1)
{
printf("%d%c",q[i].num,q[i].a);
}
else printf("%c",q[i].a);
}
printf("\n");
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: