您的位置:首页 > 其它

hdu 1018 Big Number 数学结论

2016-05-29 14:55 330 查看

Big Number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34084 Accepted Submission(s): 16111


[align=left]Problem Description[/align]
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

[align=left]Input[/align]
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

[align=left]Output[/align]
The output contains the number of digits in the factorial of the integers appearing in the input.

[align=left]Sample Input[/align]

2
10
20

[align=left]Sample Output[/align]

7
19

看到这个题就像用java写,结果超时。其实这是一道规律题:

N!的长度=log10(i)【i:2~n】+1;

然后就简单了。

#include<iostream>
#include<stdio.h>
#include<math.h>
using namespace std;
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n;
scanf("%d",&n);
double tmp=0;
for(int i=2;i<=n;i++)
tmp+=log10(i+0.0);
int ans =(int)tmp+1;
printf("%d\n",ans);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: