您的位置:首页 > 其它

HDU 1019 Least Common Multiple

2016-05-28 18:14 411 查看

Least Common Multiple

[align=center]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
[/align]
[align=center]Total Submission(s): 44912    Accepted Submission(s): 16871
[/align]

[align=left]Problem Description[/align]
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

[align=left]Input[/align]
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where
m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

 

[align=left]Output[/align]
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

 
[align=left]Sample Input[/align]

2
3 5 7 15
6 4 10296 936 1287 792 1

 
Sample Output

105
10296

题目的大意:先输入一个整数N,然后输入N组数,输入格式为M个和分别对应的M个具体的整数,最后求他们的最小公倍数。思想是从第一个到最后一个整数,从前往后两两求他们的最小公倍数。贴下自己AC的代码:

#include<iostream>
using namespace std;
int max_yue(long int x,long int y)
{
long int a=y,b=x;
if(x%y==0)return y;
else
{
x=a;
y=b%a;
max_yue(x,y);
}
}
int main()
{
int T,t; //要判断几组和每组的个数
cin>>T;
while(T--)
{
long int sum=1;
long int a;
cin>>t;
while(t--)
{
cin>>a;
sum=sum/max_yue(sum,a)*a; //之前提交两次没通过,因为之前写成 sum*a/max_yue(sum,a);先乘a可能会出现溢出的情况,要注意
}
cout<<sum<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: