您的位置:首页 > 其它

2016 女生赛 1002 Desert

2016-05-28 15:47 302 查看


Desert

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)

Total Submission(s): 0    Accepted Submission(s): 0


Problem Description

A tourist gets lost in the desert with n liters of water. He drinks positive integer units of water each day.

Write a program to calculate how many different ways the tourist can drink up the water.

 

Input

The first line contains the number of test cases T(T≤10).

Next T lines
contain the number n(1≤n≤1000000) for
each test case.

 

Output

Output consists of T lines.

Each line contains the binary number which represents number of different ways to finish up the water specified in the test case.

 

Sample Input

1
3

 

Sample Output

100

Hint
3 liters of water can be comsumed in four different ways show in the following.
1. 1 1 1
2. 1 2
3. 2 1
4. 3

If we write 4 in binary, it's 100.

 

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<cmath>
using namespace std;

int main()
{
int  t,n;
while(cin>>t)
{
while(t--)
{
cin>>n;
cout<<1;
while(--n)cout<<0;
cout<<endl;
}
}
return 0;
}
【题意】

一开始有数量为n(1<=n<=1e6)的水,

我们每天可以喝数量为任意整数的水,问你有多少种方式可以把水喝完。

【类型】

简单排列组合 隔板法

【分析】

这道题其实就是——

问你,对于整数n,可以把n拆分成多少个不同的正整数序列

我们考虑排列组合中的隔板法。

就是n个数,中间有n-1个空位,

其中每一个空位中,都可以选择插入隔板,从而把这n个数分成若干份,恰好对应本题。

显然——

如果拆成1份,方案数是C(n-1,1-1)=C(n-1,0)

如果拆成2份,方案数是C(n-1,2-1)=C(n-1,1)

如果拆成3份,方案数是C(n-1,3-1)=C(n-1,2)

...

如果拆成n份,方案数是C(n-1,n-1)=C(n-1,n-1)

对应着二项式展开

,它们的和恰好是2^(n-1)。

于是对应着,我们直接输出——

 1个1

+(n-1)个0即可。

【时间复杂度&&优化】

O(n)
以上解释出自   【2016杭电女生赛1002】【排列组合
隔板法】Desert 对n做正整序列拆分的方案数
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: