您的位置:首页 > 其它

2016女生赛 1001 Solving Order

2016-05-28 14:42 423 查看


Solving Order

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 0    Accepted Submission(s): 0


Problem Description

Welcome to HDU to take part in the first CCPC girls' competition!



As a pretty special competition, many volunteers are preparing for it with high enthusiasm.

One thing they need to do is blowing the balloons.

Before sitting down and starting the competition, you have just passed by the room where the boys are blowing the balloons. And you have found that the number of balloons of different colors are strictly different.

After thinking about the volunteer boys' sincere facial expressions, you noticed that, the problem with more balloon numbers are sure to be easier to solve.

Now, you have recalled how many balloons are there of each color.

Please output the solving order you need to choose in order to finish the problems from easy to hard.

You should print the colors to represent the problems.

 

Input

The first line is an integer T which
indicates the case number.

And as for each case, the first line is an integer n,
which is the number of problems.

Then there are n lines
followed, with a string and an integer in each line, in the i-th
line, the string means the color of ballon for the i-th
problem, and the integer means the ballon numbers.

It is guaranteed that:
T is
about 100.
1≤n≤10.
1≤ string
length ≤10.
1≤ bolloon
numbers ≤83.(there
are 83 teams :p)

For any two problems, their corresponding colors are different.

For any two kinds of balloons, their numbers are different.

 

Output

For each case, you need to output a single line.

There should be n strings
in the line representing the solving order you choose.

Please make sure that there is only a blank between every two strings, and there is no extra blank.

 

Sample Input

3
3
red 1
green 2
yellow 3
1
blue 83
2
red 2
white 1

 

Sample Output

yellow green red
blue
red white

 

#include<iostream>
#include<stdio.h>
#include<cmath>
#include<string.h>
#include<queue>
using namespace std;

struct s
{
char name[20];
int num;
friend bool operator < (s a,s b)
{
return a.num<b.num;
}
};

int main()
{
int t ,n,i;
priority_queue<s>q;
s s1;
while(cin>>t)
{
while(t--)
{
cin>>n;
for(i=0;i<n;i++)
{
cin>>s1.name>>s1.num;
q.push(s1);
}
while(q.size()>1)
{
s1=q.top();
cout<<s1.name<<' ';
q.pop();
}
s1=q.top();
cout<<s1.name<<endl;
q.pop();
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: