您的位置:首页 > 其它

acm 3 1017 背包问题

2016-05-28 11:16 519 查看
1.1017

2.Problem Q 

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)

Total Submission(s) : 152   Accepted Submission(s) : 57

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …<br>The bone collector had a big bag with a volume of V ,and along his trip of
collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?<br><center><img src=../../../data/images/C154-1003-1.jpg>
</center><br>

 

Input

The first line contain a integer T , the number of cases.<br>Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain
N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

 

Output

One integer per line representing the maximum of the total value (this number will be less than 2<sup>31</sup>).

 

Sample Input

1

5 10

1 2 3 4 5

5 4 3 2 1 

Sample Output

14

3.背包问题

4.骨头有w容量和v价值,问容量中最大能搜集多少价值的骨头(真是独特的兴趣-  -)

5.#include <iostream>

#include<stdio.h>

#include<algorithm>

#include<string.h>

#include<cmath>

#include<cstdio>

using namespace std;

int main()

{

    int T,n,Vol,i,j;

    int a;

    cin>>T;

    while(T--)

    {

        scanf("%d%d",&n,&Vol);

        int val[1005];

        int vol[1005];

        int dp[1005];

        for(i=1;i<=n;i++)

        {

            scanf("%d",&val[i]);

        }

        for(i=1;i<=n;i++)

        {

            scanf("%d",&vol[i]);

        }

        memset(dp,0,sizeof(dp));

        for(i=1;i<=n;i++)

        {

            for(j=Vol;j>=vol[i];j--)

            {

                dp[j]=max(dp[j],dp[j-vol[i]]+val[i]);

            }

        

        }

        cout<<dp[Vol]<<endl;

    }

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: