您的位置:首页 > 其它

hdu 2639Bone Collector II(01背包求第k大)

2016-05-28 11:00 288 查看






Bone Collector II

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3825    Accepted Submission(s): 1978


Problem Description

The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link:http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum
.. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.

 

Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value
of each bone. The third line contain N integers representing the volume of each bone.

 

Output

One integer per line representing the K-th maximum of the total value (this number will be less than 231).

 

Sample Input

3
5 10 2
1 2 3 4 5
5 4 3 2 1
5 10 12
1 2 3 4 5
5 4 3 2 1
5 10 16
1 2 3 4 5
5 4 3 2 1

 

Sample Output

12
2
0

题意:给出一行价值,一行体积,让你在v体积的范围内找出第k大的值......

(N <= 100 , V <= 1000 , K <= 30)

 

Dp[i][j]表示处理到了体积为i的时候第j大的是多少,

我们利用了两个辅助的数组分别记录dp[i][j](不用当前的物品),dp[i-cost[x]][j]+value[x](用了当前的物品)的前k大,然后到x这个物品求出dp[i][j]的前k大。

#include<bits/stdc++.h>
using namespace std;
int dp[1100][31],a[1100],b[1100];
int cost[110],value[110];

int main(){
int _,n,V,k;
scanf("%d",&_);
while(_--){
scanf("%d%d%d",&n,&V,&k);
for(int i=1;i<=n;i++)
scanf("%d",&value[i]);
for(int i=1;i<=n;i++)
scanf("%d",&cost[i]);
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
for(int j=V;j>=cost[i];j--){
int p;
for(p=1;p<=k;p++){
a[p]=dp[j][p];
b[p]=dp[j-cost[i]][p]+value[i];
}
a[p]=-1,b[p]=-1;
int w=1,x=1,y=1;
while(w<=k&&(a[x]!=-1||b[y]!=-1)){
if(a[x]>b[y])
dp[j][w]=a[x],x++;
else
dp[j][w]=b[y],y++;
if(w==1||dp[j][w]!=dp[j][w-1])  //如果策略不同权值相同的话,将这句话去掉便可以了
w++;
}
}
printf("%d\n",dp[V][k]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: