您的位置:首页 > 其它

poj 1797

2016-05-27 20:24 351 查看
Heavy Transportation

Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 28142 Accepted: 7524
Description

Background 

Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed
on which all streets can carry the weight. 

Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 

You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's
place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing
of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for
the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5

Sample Output
Scenario #1:
4

Source

TUD Programming Contest 2004, Darmstadt, Germany
[Submit]   [Go Back]   [Status]  
[Discuss]

题目大意:有n个城市,m条道路,在每条道路上有一个承载量,现在要求从1到n城市最大承载量,而最大承载量就是从城市1到城市n所有通路上的最大承载量。
解题思路:其实这个求最大边可以近似于求最短路,只要修改下找最短路更新的条件就可以了。

方法一:dijk:

Source Code
#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <string.h>
using namespace std;
#define INF 0x3f3f3f3f
#define N 1100

int maps[N][N];
int dist[N],vis[N];
int n,m;

void init()
{
int i,j;
for(i=0;i<=n;i++)
{
for(j=0;j<=n;j++)
{
maps[i][j]=0;
}
}
}

int dijk()
{
int i,j,index,Max;
for(i=1;i<=n;i++)
{
dist[i]=maps[1][i]; /// 这个时候dist[i]不代表从1到n的最短路径,而是最大承载量  
vis[i]=0;
}

vis[1]=1;
for(i=1;i<=n;i++)
{
Max=-1;
for(j=1;j<=n;j++)
{
if(!vis[j] && Max<dist[j])
{
Max=dist[j];
index=j;
}
}
vis[index]=1;
for(j=1;j<=n;j++)
{
if(!vis[j] && min(dist[index],maps[index][j])>dist[j])
dist[j]=min(maps[index][j],dist[index]);
}
}
return dist[n];
}

int main()
{
int i,T,a,b,c,t;
scanf("%d",&T);
for(t=1;t<=T;t++)
{
scanf("%d%d",&n,&m);
init();
for(i=1;i<=m;i++)
{
scanf("%d%d%d",&a,&b,&c);
maps[a][b]=maps[b][a]=c;
}
int ans=dijk();
printf("Scenario #%d:\n",t);
printf("%d\n\n",ans);
}
return 0;
}


方法二:ford
  貌似 超时了555555555555555(仅供参考)
#include <stdio.h>

#include <algorithm>

#include <iostream>

#include <string.h>

using namespace std;

#define INF 0x3f3f3f3f

#define N 1100

int maps

;

int dist
,vis
;

int n,m;

void init()

{

    int i,j;

    for(i=0;i<=n;i++)

    {

        for(j=0;j<=n;j++)

        {

            maps[i][j]=0;

        }

    }

}

int ford()

{

    int i,j,k;

    for(i=1;i<=n;i++)

        dist[i]=maps[1][i];

    for(i=1;i<=n;i++)

    {

        for(j=1;j<=n;j++)

        {

            for(k=1;k<=n;k++)

            {

                if(dist[k]<min(dist[j],maps[j][k]) && maps[j][k])

                    dist[k]=min(dist[j],maps[j][k]);

                   if (dist[j]<min(dist[k],maps[k][j]) && maps[k][j])

                    dist[j]=min(dist[k],maps[k][j]);

            }

        }

    }

    return dist
;

}

int main()

{

    int i,T,a,b,c,t;

    scanf("%d",&T);

    for(t=1;t<=T;t++)

    {

        scanf("%d%d",&n,&m);

        init();

        for(i=1;i<=m;i++)

        {

           scanf("%d%d%d",&a,&b,&c);

           maps[a][b]=maps[b][a]=c;

        }

        int ans=ford();

        printf("Scenario #%d:\n",t);

        printf("%d\n\n",ans);

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: