您的位置:首页 > 其它

poj 1502 MPI Maelstrom

2016-05-27 19:34 447 查看
MPI Maelstrom

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 7945 Accepted: 4883
Description

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to benchmark the new system. 

``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors
that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.'' 

``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked. 

``Not so well,'' Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.'' 

``Is there anything you can do to fix that?'' 

``Yes,'' smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.'' 

``Ah, so you can do the broadcast as a binary tree!'' 

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages
don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time
required to do a broadcast.''
Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100. 

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to
node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j. 

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus
only the entries on the (strictly) lower triangular portion of A will be supplied. 

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.
Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.
Sample Input
5
50
30 5
100 20 50
10 x x 10

Sample Output
35

Source

East Central North America 1996

题意:
给你一个不完全的矩阵,数字表示权值,x表示两点间不可达,由于自身到自身花费的时间为0,所以没有给出,由于i到j和j到i距离相同,互达时间相同
所以只给出了一半的临界矩阵。

根据给你的这个临界矩阵,让你来求从点1到其他点所花费最短时间的集合里面的的最大值。
饶了一大圈子,其实是个简单的最短路,两个模版如下:

Floyd:

Source Code
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cctype>
#include<stdio.h>
#define INF 0x3f3f3f3f
typedef long long ll;
using namespace std;

int dist[110][110];
int n;

void init()
{
for(int i=0;i<110;i++)
for(int j=0;j<110;j++)
dist[i][j]=(i==j)?0:INF;
}

int floyd()
{
int i,j,k;
for(k=1;k<=n;k++)
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
dist[i][j]=min(dist[i][j],dist[i][k]+dist[k][j]);

int ans=0;
for(i=2;i<=n;i++)
{
if(dist[1][i]>ans)
ans=dist[1][i];
}
return ans;
}

int main()
{
int i,j,ans;
char a[110];
while(scanf("%d",&n)!=EOF)
{
init();
for(i=2;i<=n;i++)
{
for(j=1;j<i;j++)
{
scanf("%s",a);
if(a[0]=='x')
dist[i][j]=dist[j][i]=INF;
else
{
int k=0;
int num=0;
while(a[k]!='\0')
{
num=num*10+a[k]-'0';
k++;
}
dist[i][j]=dist[j][i]=num;
}
}
}
ans=floyd();
printf("%d\n",ans);
}
return 0;
}


Dijkstra:

Source Code
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
#define INF 0x3f3f3f3f
#define N 110

int maps[N][N];
int dist[N],vis[N];
int n;

void init()
{
int i,j;
for(i=0;i<N;i++)
{
for(j=0;j<N;j++)
{
maps[i][j]=maps[j][i]=(i==j)?0:INF;
}
}
}

void dij()
{
int i,j,index,Min;
for(i=1;i<=n;i++)
{
dist[i]=maps[1][i];
vis[i]=0;
}

vis[1]=1;
for(i=1;i<=n;i++)
{
Min=INF;
for(j=1;j<=n;j++)
{
if(!vis[j] && dist[j]<Min)
{
Min=dist[j];
index=j;
}
}
vis[index]=1;
for(j=1;j<=n;j++)
{
if(!vis[j] && dist[index]+maps[index][j]<dist[j])
dist[j]=maps[index][j]+dist[index];
}
}

int ans=0;
for(i=2;i<=n;i++)
{
if(dist[i]>ans)
ans=dist[i];
}
printf("%d\n",ans);
}

int main()
{
int i,j;
char a[110];
while(scanf("%d",&n)!=EOF)
{
init();
for(i=2;i<=n;i++)
{
for(j=1;j<i;j++)
{
scanf("%s",a);
if(a[0]=='x')
maps[i][j]=maps[j][i]=INF;
else
{
int k=0;
int num=0;
while(a[k]!='\0')
{
num=num*10+a[k]-'0';
k++;
}
maps[i][j]=maps[j][i]=num;
}
}
}
dij();
}
return 0;
}


算是 最基本的模版了,目前只会这两种方法~
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: