您的位置:首页 > 其它

hdoj-1563-Find your present!

2016-05-27 17:43 316 查看
Problem Description

In the new year party, everybody will get a “special present”.Now it’s your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present’s card number will be the one that different from all the others.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.

Input

The input file will consist of several cases.

Each case will be presented by an integer n (1<=n<=200, and n is odd) at first. Following that, n positive integers will be given in a line. These numbers indicate the card numbers of the presents.n = 0 ends the input.

Output

For each case, output an integer in a line, which is the card number of your present.

Sample Input

5

1 1 3 2 2

3

1 2 1

0

Sample Output

3

2

位运算xjb搞一下

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int N = 200;

int num
, n, ans;

int main()
{
while (~scanf("%d", &n) && n)
{
for (int i=0; i<n; ++i) scanf("%d", &num[i]);
ans = num[0];
for (int i=1; i<n; ++i) ans ^= num[i];
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: