您的位置:首页 > 其它

ZOJ 2229 Ride to School

2016-05-27 11:27 281 查看
Ride to School
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld
& %llu
Submit Status Practice ZOJ
2229

Appoint description: 
System Crawler  (2016-05-25)

Description

Many graduate students of Peking University are living in Wanliu Campus, which is 4.5 kilometers from the main campus - Yanyuan. Students in Wanliu have to either take a bus or ride a bike to go to school. Due to the bad traffic in Beijing, many students
choose to ride a bike.

We may assume that all the students except "Charley" ride from Wanliu to Yanyuan at a fixed speed. Charley is a student with a different riding habit - he always tries to follow another rider to avoid riding alone. When Charley gets to the gate of Wanliu,
he will look for someone who is setting off to Yanyuan. If he finds someone, he will follow that rider, or if not, he will wait for someone to follow. On the way from Wanliu to Yanyuan, at any time if a faster student surpassed Charley, he will leave the rider
he is following and speed up to follow the faster one.

We assume the time that Charley gets to the gate of Wanliu is zero. Given the set off time and speed of the other students, your task is to give the time when Charley arrives at Yanyuan.

Input

There are several test cases. The first line of each case is N (1 <= N <= 10000) representing the number of riders (excluding Charley). N = 0 ends the input. The following N lines are information of N different riders, in such format:

Vi [TAB] Ti

Vi is a positive integer <= 40, indicating the speed of the i-th rider (kph, kilometers per hour). Ti is the set off time of the i-th rider, which is an integer and counted in seconds. In any case it is assured that there always exists a nonnegative Ti.

Output

Output one line for each case: the arrival time of Charley. Round up (ceiling) the value when dealing with a fraction.

Sample Input

4

20 0

25 -155

27 190

30 240

2

21 0

22 34

0

Sample Output

780

771

time小于0的不考虑,主人公到达的时间一定是和time大于0最先到达的人一起到达的

#include <cstdio>
#include <cmath>
using namespace std;
const int maxn = 10000 + 10;
int n;
int v, t;
double ti;

int main()
{
while (scanf("%d", &n), n){
double min1 = 0xFFFFFFFF;
for (int i = 0; i < n; i++){
scanf("%d%d", &v, &t);
if (t >= 0){
ti = 4.5 * 3600 / v + t;
if (ti < min1)
min1 = ti;
}
}
printf("%d\n", (int)ceil(min1));   //向上取整
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: