您的位置:首页 > 其它

POJ2342 Anniversary party(树状DP)

2016-05-26 20:24 281 查看
Anniversary party

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6190 Accepted: 3567
Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has ahierarchical(分层的)structure(结构)
ofemployees(雇员). It means that thesupervisor(监督人)
relation forms a tree rooted at therector(校长) V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee
and his or her immediate supervisor to be present. The
personnel(人事部门) office hasevaluated(评价)conviviality(欢乐)
of each employee, so everyone has some number (rating)attached(依附) to him or her. Your task is to make a list of guests with themaximal(最高的)
possible sum of guests' conviviality ratings.
Input
Employees are numbered from 1 to N. A first line ofinput(投入) contains a number N. 1 <= N <= 6 000. Each of thesubsequent(后来的)
N lines contains the conviviality rating of the corresponding employee. Conviviality rating is aninteger(整数) number in a range from -128 to 127. After
that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification h(规格)as the form:

L K

It means that the K-th employee(雇员) is an immediatesupervisor(监督人)
of the L-th employee.Input(投入) is ended with the line

0 0

Output
Output(输出) should contain themaximal(最高的)
sum of guests' ratings.
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output
5


题意:有n个人,接下来n行是n个人的价值,再接下来n行给出l,k说的是l的上司是k,这里注意l与k是不能同时出现的
思路:用dp数据来记录价值,开数组用下标记录去或者不去
则状态转移方程为:
DP[i][1] += DP[j][0];
DP[i][0] += max{DP[j][0],DP[j][1]};
其中j为i的孩子节点。这样,从根节点root进行dfs,最后结果为max{DP[root][0],DP[root][1]}。
PS:题目上没说,但是给的关系是从叶子到根的,所以才用root = k;找根。如果不是的话,设置额外数组对每个 l 进行标记,最后找没有被标记的就是根节点。

#include <stdio.h>
#include <string.h>
#define max(a,b) (a)>(b)?(a):(b)
int dp[6005][2], father[6005], vis[6005], N;
void dfs(int x)
{
vis[x] = 1;
for(int i = 1; i <= N; i++)
{
if(!vis[i] && father[i] == x)
{
dfs(i);
dp[x][1] += dp[i][0];
dp[x][0] += max(dp[i][0], dp[i][1]);
}
}
}
int main()
{
int i, l, k, root;
while(scanf("%d", &N) != EOF)
{
memset(dp, 0, sizeof(dp));
memset(vis, 0, sizeof(vis));
for(i = 1; i <= N; i++)
scanf("%d", &dp[i][1]);
root = 0;
while(scanf("%d%d", &l, &k) && l + k)
{
father[l] = k;
root = k;
}
dfs(root);
printf("%d\n", max(dp[root][0], dp[root][1]));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: