您的位置:首页 > 其它

hdu 1258 Sum It Up

2016-05-26 15:04 549 查看
[align=left]Problem Description[/align]
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

[align=left]Input[/align]
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

[align=left]Output[/align]
For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

[align=left]Sample Input[/align]

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

[align=left]Sample Output[/align]

Sums of 4:
4
3+1
2+2

2+1+1

Sums of 5:

NONE

Sums of 400:

50+50+50+50+50+50+25+25+25+25

50+50+50+50+50+25+25+25+25+25+25

//加油呀!!!

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
int t,n,flag;
int data[1005],a[1005];
int visit[1005];

bool cmp(int a,int b)
{
if(a>b) return true;
else return false;
}

void dfs(int sum,int step,int k)
{
if(sum==t)
{
flag=1;
for(int i=0;i<step-1;i++)
cout<<a[i]<<"+";
cout<<a[step-1]<<endl;
return ;
}
for(int i=k;i<n;i++)
{
if(!visit[i]&&sum+data[i]<=t)
{
visit[i]=1;
a[step]=data[i];
dfs(sum+data[i],step+1,i+1);//我原来写的是k+1,结果导致有的重复计算
visit[i]=0;
while(i+1<n&&data[i]==data[i+1])
i++;
}
}
return ;
}

int main()
{
while(cin>>t>>n)
{
if(!t&&!n) break;
memset(visit,0,sizeof(visit));
for(int i=0;i<n;i++)
cin>>data[i];
sort(data,data+n,cmp);
for(int i=0;i<n;i++)
{
if(data[i]>t) visit[i]=1;
}
flag=0;
printf("Sums of %d:\n",t);
dfs(0,0,0);
if(!flag)
cout<<"NONE"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: