您的位置:首页 > 其它

HDU1213 How Many Tables(基础并查集)

2016-05-26 10:55 309 查看
HDU1213 How Many Tables(基础并查集)

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1213

题目

Time Limit: 1000ms   Memory Limit: 32768KB


Description

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2

5 3

1 2

2 3

4 5

5 1

2 5

Sample Output

2

4

分析

并查集基础题,半年没写并查集,来道入门题练练手。开始刷图论500题了。

源码

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<vector>
#include<stack>
#include<utility>
#include<sstream>
#define mem0(x) memset(x,0,sizeof x)
#define mem1(x) memset(x,1,sizeof x)
#define mem11(x) memset(x,-1,sizeof x)

using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int INF = 0x7fffffff;
const int MAXN = 1e4+10;
const int MOD = 1000000007;

int f[MAXN];
int t,m,n;

int findAnc(int x){
int tmp = x;
while(f[tmp]!=tmp){
tmp = f[tmp];
}
return tmp;
}

void unit(int a, int b){
int fa,fb;
fa = findAnc(a);
fb = findAnc(b);
if(fa!=fb)
f[fa] = fb;
}

int main(){
/*#ifdef LOCAL
freopen("C:\\Users\\JuneLynn Bian\\Desktop\\in.txt","r",stdin);
freopen(" C:\\Users\\JuneLynn Bian\\Desktop\\out.txt","w",stdout);
#endif // LOCAL*/
cin >> t;
while(t--){
cin >> n >> m;
int a,b;
for(int i = 1; i <= n; i++)
f[i] = i;
for(int i = 1; i <= m; i++){
cin >> a >> b;
unit(a,b);
}
int cnt = 0;
for(int i = 1; i <= n; i++)
if(f[i]==i)
cnt++;
cout << cnt << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: